Updated 23th Oct, fixed the hg repo

=================================

 

This ebuild pulls the audacious source code from hg repo.

 

[code]# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-9999.ebuild,v 1.1 2008/02/02 17:56:56 chainsaw Exp $

inherit flag-o-matic mercurial

MY_P="${P/_/-}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
HOMEPAGE="http://audacious-media-player.org/"
EHG_REPO_URI="http://hg.atheme-project.org/audacious"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="altivec chardet nls libsamplerate sse2"

RDEPEND=">=dev-libs/dbus-glib-0.60
        libsamplerate? ( media-libs/libsamplerate )
        >=dev-libs/libmcs-0.7.0
        >=dev-libs/libmowgli-0.6.1
        dev-libs/libxml2
        >=gnome-base/libglade-2.3.1
        >=x11-libs/gtk+-2.10
        >=dev-libs/glib-2.14"

DEPEND="${RDEPEND}
        !media-plugins/audacious-plugins-ugly
        >=dev-util/pkgconfig-0.9.0
        nls? ( dev-util/intltool )"

PDEPEND=">=media-plugins/audacious-plugins-9999"

src_compile() {
        cd ${WORKDIR}/${PN}
        ./autogen.sh
        econf \
                --enable-dbus \
                $(use_enable altivec) \
                $(use_enable chardet) \
                $(use_enable nls) \
                $(use_enable sse2) \
                $(use_enable libsamplerate samplerate) \
                || die

        emake || die "make failed"
}

src_install() {
        cd ${WORKDIR}/${PN}
        make DESTDIR="${D}" install || die
        dodoc AUTHORS NEWS README

        dodoc "${WORKDIR}"/README
}

pkg_postinst() {
        elog "Note that you need to recompile *all* third-party plugins for Audacious 9999"
        elog "Plugins compiled against 1.3 will not be loaded."
}[/code] 

Go to top
JSN Boot template designed by JoomlaShine.com