I was trying to upgrade my Filezilla from 3.0.3 to 3.0.4 today and getting this error:

 

[code]checking for wxWidgets version >= 2.8.6... no (version 2.6.4 is not new enough)
configure: error:
                wxWidgets must be installed on your system
                but wx-config script couldn't be found.

                Please check that wx-config is in path, the directory
                where wxWidgets libraries are installed (returned by
                'wx-config --libs' command) is in LD_LIBRARY_PATH or
                equivalent variable and wxWidgets version is 2.8.6 or above.


!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/portage/net-ftp/filezilla-3.0.4/work/filezilla-3.0.4/config.log[/code]

 

 

 

 

After a few minutes of googling without any possitve result, I found out that I need to set eselect wxwidgets to 2.8.6

so:

[code]eselect wxwidgets list
Available wxWidgets profiles:
  [1]   gtk2-ansi-release-2.6 *

  [2]   gtk2-unicode-release-2.6
  [3]   gtk2-unicode-release-2.8[/code]

then:

[code]eselect wxwidgets set 3
Setting wxWidgets profile to gtk2-unicode-release-2.8

eselect wxwidgets list
Available wxWidgets profiles:
  [1]   gtk2-ansi-release-2.6

  [2]   gtk2-unicode-release-2.6
  [3]   gtk2-unicode-release-2.8 *[/code]

Then FileZilla was happily compiled.

Go to top
JSN Boot template designed by JoomlaShine.com